Skip to content

Venafi Control Plane Operator releases

Learn about current and past releases of Venafi Control Plane Operator. ​

Latest release

​ The latest stable version of Venafi Control Plane Operator is v1.1.0.

The latest version of Venafi Control Plane Operator is certified and available on the Red Hat Ecosystem Catalog.

​Release 1.1.0

Venafi Control Plane Operator 1.1.0 was released on June 14, 2024.

Key features

This release adds new configuration fields and resolves installation issues with Venafi Firefly, Venafi Kubernetes Agent and CSI driver for SPIFFE components.

  • New region field as a global option

    The region to pull the container images from for all components. The default value is us.

  • New clientID fields

    A new required clientID has been added for the Venafi Firefly and Venafi Kubernetes Agent components. This is the ID of the Venafi Control Plane service account to be used by the components.

  • New trustDomain field for CSI driver for SPIFFE

    This is a required field used to specify the SPIFFE trust domain.

    For more information on all the Venafi Control Plane Operator configuration options, see the Sample VenafiInstall custom resource.

  • Install improvements

    This release also includes a fix that prevented installs of Venafi Firefly, Venafi Kubernetes Agent and CSI driver for SPIFFE components.

  • Default component versions for this release

    The following is a complete list of the component versions installable by default in release 1.1.0.

    Component Default version for this release
    Approver Policy v0.14.1
    Approver Policy Enterprise v0.17.0
    AWS Private CA Issuer v1.2.7
    cert-manager v1.15.0
    CSI driver v0.8.1
    CSI driver for SPIFFE v0.6.0
    Firefly v1.3.4
    Trust Manager v0.11.0
    Venafi Connection v0.1.0
    Venafi Enhanced Issuer v0.14.0
    Venafi Kubernetes Agent v0.1.48

​Release 1.0.2

Venafi Control Plane Operator 1.0.2 was released on June 11, 2024.

Key features

This release addresses an installation issue with Venafi Firefly.

  • New acceptTOS field for Firefly installs

    A new field showing that users accept the terms of service when installing Firefly has been added. This must be set to true when installing the component. For more information, see component install parameters.

  • Go dependency updated

    The version of Go used by Venafi Control Plane Operator has been up v1.22.3. This fixes CVE-2024-24787.

  • Default component versions for this release

    The installable component versions for this release have also been updated. The following is a complete list of the component versions installable by default in release 1.0.2.

    Component Default version for this release
    Approver Policy v0.14.1
    Approver Policy Enterprise v0.17.0
    AWS Private CA Issuer v1.2.7
    cert-manager v1.15.0
    CSI driver v0.8.1
    CSI driver for SPIFFE v0.6.0
    Firefly v1.3.4
    Trust Manager v0.11.0
    Venafi Connection v0.1.0
    Venafi Enhanced Issuer v0.14.0
    Venafi Kubernetes Agent v0.1.48

​Release 1.0.0

Venafi Control Plane Operator 1.0.0 was released on May 29, 2024.

Key features

This is the initial release of Venafi Control Plane Operator.

  • Default component versions for this release

    The following is a complete list of the component versions installable by default in release 1.0.0.

    Component Default version for this release
    Approver Policy v0.14.0
    Approver Policy Enterprise v0.16.0
    AWS Private CA Issuer v1.2.7
    cert-manager v1.14.5
    CSI Driver v0.8.0
    Firefly v1.3.4
    Trust Manager v0.9.2
    Venafi Connection v0.0.20
    Venafi Enhanced Issuer v0.13.3
    Venafi Kubernetes Agent v0.1.47

Supported Red Hat OpenShift versions

This version of Venafi Control Plane Operator supports the following versions of Red Hat OpenShift:

  • 4.15
  • 4.14